Avisoft logo

SASLab Manual


Main window : Tools > Batch and Real-time processing function


Print multiple line spectrogram A spectrogram is generated and printed as a multiple line image.

Print single line spectrogram A spectrogram is generated and printed as a single line image.

Save multiple line spectrogram A spectrogram is generated and saved as a multiple line image. The filenames of the graphics files will be derived from the names of the sound files. The extension .WAV will be replaced by .WMF, .TIF and .BMP.

Save single line spectrogram A spectrogram is generated and saved as a single line image. The filenames of the graphics files will be derived from the names of the sound files. The extension .WAV will be replaced by .WMF, .TIF and .BMP.

IIR-filter Each sound file will be filtered using the parameters defined in the menu Edit > Filter > Time domain IIR filter.... The original sound files will be replaced by the output of the filtering process.

FIR-filter Each sound file will be filtered using the parameters defined in the menu Edit > Filter > Time domain FIR filter.... The original sound files will be replaced by the output of the filtering process.

Frequency Domain Transformation Each sound file will be filtered using the parameters defined in the menu Edit > Filter > Frequency Domain Transformation.... The original sound files will be replaced by the output of the filtering process.

Save one-dimensional transformation (WMF) The function selected on the drop-down menu Analyze > One-dimensional transformation... will be executed on the sound files. The results will be saved as a WMF-graphics file. The filenames of the graphics files will be derived from the names of the sound files. The extension .WAV will be replaced by .WMF.

Save one-dimensional transformation (ASCII) The function selected on the drop-down menu Analyze > One-dimensional transformation... will be executed on the sound files. The results will be saved into separate ASCII files The filenames of the ASCII files will be derived from the names of the sound files. The extension .WAV will be replaced by .TXT.

Save one-dimensional transformations into a single ASCII file The function selected on the drop-down menu Analyze > One-dimensional transformation... will be executed on the selected sound files and the data will be saved in a single ASCII file. In case one of the spectral functions has been selected and the Spectral Characteristics tool is activated, then these spectral characteristics measurements will be saved rather than the underlying spectral data set. The resulting text file will be saved into the same directory as the selected sound files and it’s filename will be derived from the name of the selected one-dimensional transformation (e.g. “Envelope.txt”). If the option Tools > DDE Parameters / LOG file > Enable Dynamic Data Exchange has been activated and an Excel worksheet is open, the results will also be transferred into that Excel worksheet.

Save mean spectra into a single ASCII file A spectrogram will be calculated by using the parameters selected from Analyze > Spectrogram Parameters... and the mean spectrum of the entire spectrogram (sound file) will be saved into a single ASCII file. This file will be saved into the same directory as the selected sound files and it’s filename will be “mean spectra.txt”. The second row of the file (labelled "frequency") reports the frequencies of the individual magnitudes of the spectra. If the option Tools > DDE Parameters / LOG-file > Enable Dynamic Data Exchange has been activated and an Excel worksheet is open, the results will also be transferred into that Excel worksheet.

Save ASCII/Binary spectrogram A spectrogram is generated and saved as ASCII or binary file. The filenames of the files will be derived from the names of the sound files. The extension .WAV will be replaced by .TXT or .SON.

Sampling Frequency Conversion Each sound file will be converted using the settings made in the command Edit > Format > Sampling Frequency Conversion.... The source sound files will be replaced by the output this process.

Restore the original time scale of time-expanded recordings Each sound file will be converted using the settings made in the command Edit > Format > Restore the original time scale of a time-expanded recording.... The source sound files will be replaced by the output this process.

8<-->16 Bit Conversion Each sound file will be converted from 8 to 16 if the source file is 8 bit. 16-bit files will be converted to 8 bits. The source sound files will be replaced by the output this process.

Stereo->Mono Each sound file will be converted into a mono file. The conversion will be done according to the settings made in the corresponding command Edit > Format > Stereo->Mono.... The source sound files will be replaced by the output this process.

Automatic parameter measurements A spectrogram is generated from each sound file and the measurements defined in the spectrogram window menu Tools > Automatic parameter measurements setup... will be made. The results will be saved in a LOG file or will be transferred by DDE as specified on the menu item File > DDE Parameters / Log file....

Automatic parameter measurements; save elements as labels Same as above, except that the detected elements will also be saved as section labels into the original .wav files.

Automatic parameter measurements; remove gaps A spectrogram is generated from each sound file and the element separation of the Automated Parameter Measurements tool is carried out. The gaps between the detected elements will then be removed from the wav file (similar to the APM window command Export/Remove gaps between detected elements from sound file…).

Sound file format conversion The selected sound files will be saved in the format specified in the File > Save As... dialog box. The original files will not be overwritten or deleted

Change Volume The selected sound files will be modified according to the current settings in the Edit > Change Volume... dialog box. The original files will be replaced by their modified versions.

Shred into numbered .wav files The selected sound files will be shredded into sequentially numbered .wav files according to the settings made in the File > Specials > Shred into numbered .wav files.... The original .wav files will remain unaffected.

Remove silent sections The silent sections within the selected sound files will be removed according to the settings made under Edit > Compress > Settings.... The original files will be replaced by their compressed versions.

Save events into numbered .wav files The sound events within the selected sound files will be copied into sequentially numbered .wav files. The (threshold-based) event detection is executed according to the settings made under Edit > Compress > Settings.... The original .wav files will remain unaffected.

Save labeled sections into numbered .wav files The labeled sections of the selected sound files will be copied into sequentially numbered .wav files. The margin parameter specified under Tools/Labels/’Save labeled sections into numbered .wav files…’ will be used. The original .wav files will remain unaffected.

Pulse Train Analysis A Pulse Train Analysis is performed for each file (according to the settings made in Analysis/Pulse Train Analysis). The detected pulses and pulse groups will be saved into ASCII files. The ASCII file names are a combination of the original sound file name and the strings _pulses.txt and _groups.txt.

Split multichannel files into mono files (into the same folder) The selected multichannel files (sound files containing more than one channel) will be split into mono files. The original multichannel files will remain unaffected. The file names of the newly created mono files will consist of the name of the original file and the channel number (filename.wav ? filename_0.wav ; filename_1.wav; filename_2.wav; …)

Split multichannel files into mono files (into separate folder) The selected multichannel files (sound files containing more than one channel) will be split into mono files. The original multichannel files will remain unaffected. The resulting mono files will be saved into the newly created folders channel1, channel2, channel3… The filenames of the created mono files will be identical to the names of the original multichannel files.

Classify labeled sections The labeled sections of the selected sound files will be classified according to the settings made in Tools > Labels > Classify labeled sections.... Additionally, the classification report table will be saved as an ASCII file (filename.txt). The ASCII file filename_stat.txt reports the number of events that have been assigned to each class.

Classify .wav or .son files (show results in a single table) The selected .wav or .son files will be classified (by using a spectrogram image cross correlation technique) according to the settings made in the Classification Settings dialog box that will be launched after clicking at the Start button on the Batch processing dialog box. The classification results can be exported by means of the Copy table or Save table buttons on the Classification Report window.

Detect and classify sound events The sound events in the selected sound files will be detected and classified according to the settings made in Analyze > Specials > Detect and classify waveform events.... The classification report table will be saved as an ASCII file (filename.txt). The ASCII file filename_stat.txt reports the number of events that have been assigned to each class.

Scan for template spectrogram patterns The soundfiles will be scanned for template spectrogram patterns according to the settings made in Analyze > Specials > Scan for template spectrogram patterns.... The classification report table will be saved as an ASCII file (filename.txt). The ASCII file filename_stat.txt reports the number of events that have been assigned to each class.

Detect, classify and save sound events This command is similar to the above command Detect and classify sound events, except that it will additionally save the detected events into sequentially numbered .wav files. This command might be used for scanning large numbers of long sound files for certain vocalizations.

Scan for template spectrogram patterns and save This command is similar to the above command Scan for template spectrogram patterns, except that it will additionally save the detected events into sequentially numbered .wav files. This command might be used for scanning large numbers of long sound files for certain vocalizations.

Template Cross Correlation on short files This command is similar to the above command Scan for template spectrogram patterns, except that it is prepared for classifying short .wav or .son files containing only a single call. That way, the maximum cross-correlation coefficient across the entire .wav file is being determined against each template file and listed in a compact results table.

Noise reduction filter The selected sound files will be noise-filtered according to the settings made in the command Edit/Filter/Noise Reduction… The original sound files will be replaced by output of the noise gate filter.

Georeference labels / .wav files The labels (or filename prefixes) of the selected files will be georeferenced according to the settings made in the command Tools/Labels/Georeference labels… The results will be written into a single .gpx, .kml, .shp or .txt file.

Sort files using APM classes The selected sound files will be sorted into class-specific subfolders that are determined by using the classification option of the Automatic Parameter Measurements tool.

Sort files using template spectrograms (triggered CCF) The selected sound files will be sorted into class-specific subfolders that are determined by using the command Analyze > Specials > Detect and classify waveform events…

Sort files using template spectrograms (continuous CCF) The selected sound files will be sorted into class-specific subfolders that are determined by using the command Analyze > Specials > Scan for template spectrogram patterns…

Modify BWF (bext chunk) metadata Modifies the bext chunks of the selected .wav files. If there is already a bext chunk in a file, then the new data can either be appended to the existing data (option “append”) or it can replace the existing data (option “overwrite”).

Save application-specific (dXML chunk) metadata Saves uniform dXML records into the selected .wav files.

Create virtual Metadatabase Collects various metadata items of the selected .wav files into a XML-formatted metabase.

Insert silent margins Silent sections of the specified duration will be inserted at the start and the end of each file.

Scan frequency contour and amplitude envelope Scans the frequency contour and amplitude envelope as setup in the corresponding spectrogram window command on the Tools menu and saves the resulting .at and .ft files.

Create envelope (*.env) sidecar files Creates .env sidecar files according to the selected Overview Display Parameters and the envelope resolution (FFT frames) setting on the command File > File Open Settings…

Create section labels from waveform events Executes the command Tools > Labels > Create section labels from waveform events... in a batch process.

Insert USG DIO timecode / Pulse Train / Single Pulse Executes the command File > Specials > UltraSoundGate DIO > Insert timecode / pulse train / single pulse... in a batch process.

Classify Element Sequences Executes the command Tools > Labels > Classify Element Sequences in a batch process.

Calculate Acoustic Complexity Index (ACI) Executes the spectrogram window command Tools > Calculate Acoustic Complexity Index (ACI)... in a batch process. The results will be saved into the log file titled Acoustic Complexity Index.* that will be saved into the folder of the original .wav files. If the option display ACI versus time is activated, the batch function will save a time series of ACI values rather than a single the ACItot value of the entire file.

Save spectrogram images of labelled sections Executes the spectrogram window command Tools > Save spectrogram images of labelled sections... in a batch process. The created image files will be stored in the same directory as the original .wav or .son files.

Add analog DI track channel Executes the main window command File > Specials > UltraSoundGate DIO > Add analog DI track channel in a batch process.

Standardize section label durations Executes the main window command Tools > Labels > Standardize section label durations / Convert labels... in a batch process.

Mix with clipboard content Executes the main window command Edit > Mix in a batch process.

Copy labels Copies the labels of the currently opened .wav file to a batch of .wav files.

Remove gaps between section labels Executes the main window command Edit > Compress > Remove gaps between section labels in a batch process.


Avisoft Bioacoustics last modified on 11 August 2022