Avisoft logo

SASLab Manual


Spectrogram window : File > Save spectrogram images of labelled sections


This dialog box exports continuously numbered images (or binary spectrogram files) of the labelled sections. This tool can be used to streamline the process of preparing manually labelled template files that are required for classification purposes.



Destination directory : Select here the directory where the created image files should be saved.

File format : Defines the image file format of the exported spectrogram images (WMF, TIFF, BMP, PNG or the custom Avisoft SON format for saving binary spectrograms).

Start index : Defines the start index of the serial number for the numbered image output files.


Filename format : The Filename format section defines the structure of the image filenames:

create subfolders based on the label texts (for VocalMat) : The label texts (class names) of the section labels are being used as subfolders, which supports the required image file structure of the VocalMat program by Fonseca et al.

use the label text as filename prefix : The label texts (class names) of the section labels are added to the filename as a prefix, which supports the template-based spectrogram cross-correlation classification tools of Avisoft-SASLab Pro (commands Analyze > Specials > Detect and classify waveform events..., Analyze > Specials > Scan for template spectrogram patterns... and Tools > Labels > Classify labeled sections...).

use the serial number only : The filenames just contain the serial number.

add the original .wav file name : Adds the filename of the .wav file to the image filename.

A Preview of the selected file name format is shown at the bottom of the dialog box.

Avisoft Bioacoustics last modified on 31 July 2020