Avisoft logo

SASLab Manual


Graphic Synthesizer


The graphic synthesizer tool supports the comfortable synthesis of complex signals by defining the parameter evolution graphically. The synthesizer consists of a set of controlled sine generators that allow emulating many animal sounds.



In order to keep the operation easy, only those parameters needed for the current task can be activated and displayed for graphical editing. The interactively generated parameter sets can be saved as arrangements (.arr files). In contrast to the dialog-based synthesizer the graphic synthesizer is suited for complex sequences containing of several elements.

The graphic synthesizer window is launched from the main window (drop-down menu Tools > Synthesizer (graphically)...). At first the parameters to be controlled graphically must be selected from the Graphic Synthesizer Parameters dialog box (File > Setup...). The Overall amplitude and Fundamental frequency are activated by default.

The synthesizer window displays all active parameters in separate diagrams that all have a unique time axis. These diagrams are empty after the initial launch of the Graphic Synthesizer or after executing the command File > New.

A new sound element can be inserted by clicking into one of the diagrams at the desired start point and dragging the mouse cursor to the desired end point while the mouse bottom is pressed. This new element will also be displayed in all other parameter diagrams. For these parameters the default values defined in the Graphic Synthesizer Parameters dialog box will be assigned.

A new point can be inserted into an existing element by clicking at the element (the mouse cursor will change to an up arrow ). Existing points can be moved by the mouse. Entire elements can be moved by the mouse while the Shift key is pressed (the mouse cursor will change to ). Single points can also by edited numerically. To do this the reticule marker must be positioned at the point to be edited. This can be done by mouse or by using the menu options (Next element , Next point , Previous point , Previous element ). The numeric edit field is located on the top of the window. An arrangement can alternatively modified by editing the arrangement text files (.at, .ft, ...) in a text editor.

The editing commands (drop-down menu Edit) allow editing several elements at once.

For more accurate drawing it is possible to zoom into the graphs ( or Tools > Zoom and Tools > View or by double clicking on the Y-axis). These techniques are very similar to other graphics applications.

The current state of the arrangement can by played back anytime from the command File > Play . The synthesized arrangement can be inserted into the main window using the command File > Insert .

Example of amplitude modulation (AM) The spectrogram and waveform below shows a synthesized signal with the AM frequency sweeping from 10 to 1000 Hz. All other parameters are constant (Fundamental frequency = 5 kHz, Modulation depth of AM = 100%)


Example of frequency modulation (FM) The spectrogram below shows a synthesized signal with the FM frequency sweeping from 10 to 1000 Hz. All other parameters are constant (Fundamental frequency = 5 kHz, Frequency change of FM = 3kHz)


The synthesizer window contains the following drop-down submenus:

File
Tools
Edit
View

Avisoft Bioacoustics last modified on 15 April 2019