Avisoft logo

SASLab Manual


Spectrogram window : Tools > Automatic parameter measurements >


On the spectrogram window it is possible to measure time and frequency parameters automatically. To accomplish that, the spectrogram is scanned and single calls or song elements are separated. This element detection is done by a threshold comparison with a hold-time mechanism. Then various parameters at certain locations within each of the detected elements can be measured. These locations can be for instance the start, end, center or the point of maximum amplitude. Various parameters such as peak frequency, amplitude at peak frequency, bandwidth, quartiles or number of harmonics (peaks) can be determined at these locations. Additionally, these frequency parameters may also be derived from the average or maximum spectrum of the entire element.

All measured parameters will be displayed graphically within the spectrogram, which allows verifying the operation of the automatic parameter measurements tool and simplifies the process of finding the best settings (thresholds and hold time). The measured parameters will also be displayed in a separate table where they can be exported for further processing. The settings for all these measurements are defined on the drop-down command

Tools > Automatic parameter measurements > Automatic parameter measurements setup...

Update Updates the Automatic Parameter Measurements results based on the current settings.

Copy parameter measurement values Copies the parameter measurement values of the marked or visible section into the clipboard. Optionally these values will be transferred by DDE or will be written into a LOG file (File > Data export > DDE Parameters / Log-File).

Copy parameter measurement values for entire file Copies the parameter measurement values of the entire spectrogram (spectrogram (not only the visible section) into the clipboard. Optionally these values will be transferred by DDE or will be written into a LOG file (File > Data export > DDE Parameters / Log-File).

Copy parameter measurement values in transposed order Copies the parameter measurement values that are currently visible on the numeric display window in transposed order (rows and columns reversed) into the clipboard.

Copy parameter measurement headings Copies the headings for the currently activated parameters into the clipboard. This supports navigation through the exported measurement values. Optionally these headings will be transferred by DDE or will be written into a LOG file (File > Data export > DDE Parameters / Log-File).

Save detected elements into numbered .wav files...

Remove gaps between detected elements...

Delete gaps between detected elements...

Copy detected elements into section labels...

Copy peak frequencies into labels Labels indicating the peak frequencies at the selected Location of measurements will be created. The last label of each element will be marked with a dot (period) in the label text. This enables the subsequent grouped export of labels (Tools/Labels/Export label data…). In this way, it is for instance possible to export frequency contours that have been edited manually (the created labels can be moved prior to exporting them).


Automatic Response Setup...


Move to previous element Moves the spectrogram view to the previous detected element.

Move to next element Moves the spectrogram view to the next detected element.

Avisoft Bioacoustics last modified on 06 July 2019